/ / Comment puis-je savoir quelle version de Zurb Foundation I fonctionne - zurb-foundation

Comment savoir quelle version de Zurb Foundation I fonctionne - zurb-foundation

Y a-t-il quelque chose que je puisse entrer dans la ligne de commande pour savoir quelle version je cours?

Réponses:

11 pour la réponse № 1

Sans en savoir plus sur votre situation exacte, le plus simple est d'ajouter le JavaSscript suivant après avoir initialisé Foundation ($(document).foundation();).

Le produit final ressemblerait à ceci:

$(document).foundation();
$(document).ready(function(){
alert("Foundation Core Version: " + Foundation.version);
alert("Foundation DropDown Version:" + Foundation.libs.dropdown.version);
});

La première alerte vous donne la version de base de Foundation que vous utilisez dans foundation.js et foundation.min.js.

Si vous n'utilisez pas foundation.min.js, qui charge Foundation Core et tous les plugins JavaScript tels que: accordéon, menu déroulant, menu déroulant, onglet, etc., vous pouvez utiliser la deuxième alerte. Il vous donnera la version du plugin spécifié.

Vous pouvez visiter la Fondation Docs on Configuration JavaScript pour en savoir plus sur foundation.min.js et les plugins tels que foundation.accordion.js, foundation.dropdown.js, foundation.joyride.js, foundation.tab.js et ainsi de suite.

J'ai seulement testé le JavaScript sur Fondation 5.0.3, mais je pense que cela fonctionnera sur les anciennes versions.

J'espère que ça aide.


4 pour la réponse № 2

recherche dans foundation.js pour "version"

window.Foundation = { nom: "Fondation",

version : "5.3.1",

2 pour la réponse № 3

Pour ceux qui cherchent un moyen facile de le faire:

Pour rechercher une version de base d'un projet, consultez /bower_components/foundation/bower.json

il devrait avoir quelque chose de similaire à:

"homepage": "https://github.com/zurb/bower-foundation", "_release": "5.2.1",

Pour autant que je sache, il n'y a rien que vous puissieztapez pour vérifier la version, vous pouvez taper "version de base" mais cela reviendra probablement avec la version 1.0.4 qui, je pense, est la version installateur ou boussole, ce n'est pas la version de Foundation.