/ / Die Installation von EclipseFP schlägt auf der URL fehl - haskell, eclipse-plugin

Die Installation von EclipseFP schlägt auf der URL fehl - haskell, eclipse-plugin

In meinen Studien musste ich Haskell lernenselbst und in Haskell zu codieren. Ich habe viel über die Installation von Plugins für Haskell gesucht und festgestellt, dass dies in der Eclipse-Entwicklungsumgebung, Version 3.7 oder höher, möglich ist. Ich habe das von hier heruntergeladen: http://filehippo.com/download_eclipse_classic_64/tech/11757/ (Wenn Sie auf diese Seite gehen, wird es sofort auf Ihren Computer heruntergeladen!). Ich folgte Schritt für Schritt nach den Installationsanweisungen, die ich hier gefunden habe: http://eclipsefp.github.io/install.html

Ich habe die URL des Plugins hinzugefügt, die dort angegeben wurde,und alles war gut. Aber dann, als ich versuchte, EclipseFP zu verwenden, indem ich zu Fenster> Perspektive öffnen> Andere ... gehe und Haskell auswähle - habe ich den folgenden Fehler bekommen: "Probleme beim Öffnen der Perspektive" net.sf.eclipsefp.haskell.ui.HaskellPespective "". Und das ist es. Ich kann EclipseFP nicht benutzen ... Hat jemand eine Lösung? Bitte!

P.S. Ich habe auch versucht, Haskell auf intellij zu installieren, wie jemand hier erklärt hat, aber es hat auch nicht funktioniert. Ich wusste nicht, wie ich ein Haskell-Programm wirklich öffnen sollte.

Danke noch einmal!

Antworten:

1 für die Antwort № 1

EclipseFP ist also kein aktives Projekt mehrSie werden Mühe haben, Unterstützung zu bekommen. Die meisten Leute, die Haskell benutzen, benutzen Emacs oder Vim. Sie werden wahrscheinlich Atom leichter finden, um damit anzufangen. Atom mit den folgenden Paketen funktioniert für mich:

  • Autocomplete-Haskell
  • haskell-ghc-mod
  • haskell-hoogle
  • ide-haskell (das ist das Hauptpaket)
  • ide-haskell-cabal
  • ide-haskell-repl
  • Sprache-Haskell

1 für die Antwort № 2

Wie GarethR sagt, ist EclipseFP nicht mehr aktiv. Sie können sich auch Leksah anschauen, die in Haskell für Haskell geschrieben wurde.