/ / SyntaxError: fehlt; vor Anweisung {"Version": 3, "Datei": "jquery-2.1.0.min.js", "Quellen": ["jquery-2.1.0.js" - javascript, jquery, jquery-ui

SyntaxError: fehlt; vor Anweisung {"Version": 3, "Datei": "jquery-2.1.0.min.js", "Quellen": ["jquery-2.1.0.js" - javascript, jquery, jquery-ui

SyntaxError: fehlt; vor Aussage

{"version":3,"file":"jquery-2.1.0.min.js","sources":["jquery-2.1.0.js"

Dies ist der Fehler, den ich in Asp.Net MVC 4.0 beim Arbeiten mit neuen Skript aktualisiert Paket von jquery zu 2.1.0.js.

Ich aktualisierte meine asp.net mvc 4.0 Lösung zu spätem jquery-ui, das den NuGet Paketkonsolenmanager benutzt und dieses Problem gegenüberstellt

Kann jemand irgendeine Lösung vorschlagen, warum dies geschieht?

Antworten:

1 für die Antwort № 1

Ich bin mit diesem Fehler aufgewachsen, als ich das hinzugefügt habe .map Datei als Skript in

<script src="/js/jquery-1.11.1.min.map"></script>

Aber eigentlich .map Datei ist kein Javascript, daher kann es dort nicht angegeben werden.

Es kann auch in Ihrem Fall ein Problem sein.